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« EImer FEM

« Finite element software package for multiphysical
problems

« Multiple modules within Elmer FEM:

 Elmer Solver: Kernel of EImer FEM, which
performs FEM computations

« Elmer Grid: Module for mesh
preparation/conversion

« Elmer GUI: Graphical user interface built around
ElmerSolver with the intention to ease the case
preparation and computation for users

« Open source

« Source code and documentation available at

GitHub - EImerCSC/elmerfem: Official git repository of Elmer FEM
software
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https://github.com/ElmerCSC/elmerfem
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File Edit View Sources Filters Tools Catalyst Macros Help
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» Contours and isosurfaces for scalar and vector fields
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» Advanced data manipulation through Python R OS2 5 B
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https://github.com/Kitware/ParaView
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Najbolj uporabljani programi

)l Terminal
) @ Web Browser (Firefox)
O n VI Z i Osebne datoteke (Domov)
. . . % Text Editor (Emacs)
* COnneCt '[O V|Z US|ng NOMaCh|ne Terminal = Terminal Program Quake-Style (Yakuake)
« Click bottom left icon on desktop to open the start menu 5 — e
. o fik "
(See figure) i :
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Software loading and running  SCtrain

* To open Elmer GUI:

« To load Elmer into environment, type into terminal
* module load elmer/foss-2018b

 To run Elmer GUI
e ElmerGUI

* To open ParaView

« To load ParaView into environment, type into terminal
* module load ParaView/5.8.1-foss-2020b-mpi

 To run ParaView
* paraview
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Loaded elasticbeam-2D  SCtrain

« Case definition
. 2D case Load q(x)
* Homogeneous, elastic beam, defined /5|
on x — y plane

%
(length 1m and thickness 0.1m) ?
?

Beam Q

* Rigid support at the wall
» Space dependent mechanical load,
which grows linearly from O to g, = 1e7N

« Goal
» Obtain the displacement of the beam




Loaded elastic beam - 2D
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« Mathematical definition of the problem

» Domain of computation:
 Beam area ()
« Boundary conditions
* Mechanical load I';
* No displacement at T,
« ZeroloadonT; and T,

* Problem solution

( —Vo =0
o = Atr[e(u)]I + 2us(u)
9 u=20
on =20
L on = —q

on ()

on ()

only,
only and I'_2

on I3

Wall

ANRNNNNN

Load q(x)

Beam Q2

; (load)

4

2P

(no displacement)

rl (no Ioad) (nO Ioad)
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Case preparation - overview  SCtrain

1. Definition of domain of computation (Elmer GUI)
» Mesh preparation/definition

2. Definition of type of physical problem (Elmer GUI)
 Definition of equation to be solved

Definition of material properties (Elmer GUI)
Definition of boundary/initial conditions (Elmer GUI)
Computation (Elmer GUI)

Postprocessing of results (ParaView)

o 0k W
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Case preparation SCtrain

1. Definition of domain of computation (Elmer GUI)

“ New project...

* Import mesh into Elmer GUI Load project..
i File_>open ;avepr::,ct

Save project as...

« Navigate to your folder and select beam.grd
== Load mesh...
 Use Mouse wheel/left button to rotate and zoom mesh b seve. criss
Save as...
b,'z,',!'fzv Sif Run Melp 00000 , - o —— Definitions...
[ob:ct i ﬂlz:d L?\-H/ “ Tl selrreln D'H 2P B Save picture as...
- €3 Exit curi+Q
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Case preparation SCtrain

GO to Model->summary to observe mesh TR —
information S cavon

- Check that mesh contains 3221 nodes v

« How many surface elements are in the mesh? iyt

« What is the type of the surface elements? TS:Z:Z““

» Triangles, quadrangles? Clear al
 Check Elmer documentation — —
to see ID numbers for different souncme sex =
elements 1053 i

Soudary conitons: ;,
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2. Definition of type of physical problem

* In Model->Setup.. one can define
properties related to the simulation, such
as results directory, input mesh directory,
name of output file, constants, etc...

 Make sure the simulation type IS set
{0 Steady state

ElmerGul
File Mesh Model View Sif Run Help

o T
»

Object Equation
i Ceomt Material
Input
F Body
@ Boun.  Body force
= | de > ?
M“‘g' : Initial condition
qL
Matey =
Body Boundary condition
Intial
Boun. ™ Set body properties
) set boundary properties
Summary...
Clear all

Setup

?2 O X

-Header

N Check keywords warn

MeshDR |

Include path |

Results directory |

Froe text

Simulation

Max. output level |5

] steady state max. iter |1

Coordinate system [Cartesian

~] Timestepping method |[BDF

L] Ll

Coordinate mapping [1 2 3

Simulation type

BDF order 1

+| Timestep intervals |

Output intervals B

Timestep sizes

Coordinate Scaling |

Angular Frequency

Solver input file [case.if

|
|
Post file I‘ ase.vtu

Free text

—Constants

Gravity [o-1009.82

Boltzmann [1.3807e-23

Stefan Boltzmann  [5.67=-08

Unit charge [1.602e-19

Vacuum permittivity [8.8542e-12

Free text

v Apply

Ll

11



SUPERCOMPUTING
KNOWLEDGE
PARTNERSHIP

Case preparation SCtrain

* In Model->Equation->Add.. 0N Can |[rcmmmmme
select equations to be solved during the e ———
computation. For the bending of beam, e ‘
select Linear elasticity tab B e i

* Tick checkboxes Active and Plane
stress ——

» Assign the equation to the Mesh body —— |

(Tick the box in Apply to body) i e —

* In the end, click OK to accept new e e ot e T
changes e —

12
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Case preparation SCtrain

E Material =101%

3. Definition of material properties o o o 0 B e

Properties =

- The material of the beam in our Study is [ & mmm
iron with Poisson’s ration of 0.29 and g ee—— < |

Y n ) m I f 1 9 3 R 1 O 9 N 2 m“:; » Set body properties Strain 6-vector
u u u . J ' 1, Boun B Set boundary properties Material pricipal directions
Rotate Elasticit y Tensor r

Tz
w
[
3
3
W
¥
T
' X

* Click on Model->Material->Add... — ' =
e Click on Material library and - ,
select Iron (generic) e T
e Click OK
* Tick box 2pply to bodies to setthe
material to mesh.
e Click OK

13
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Case preparation SCtrain

4. Definition of boundary conditions
» To define a boundary condition, click on Model->Boundary condition->Add..
* Navigate to Linear elasticity
« Here, we can define displacements and loads on the mesh boundaries

fle Mesh | Model View Sif Run Help = fle Mesh Model View Sif Run Help

Traction boundary conditions

General | Electrostatics Heat Equation | Helmholtz Equation Linear elasticity Mesh Update Mz © y " |
| e Setup... HJ/{ I | | L | U SsHid ||| )] .7 @8 o4 se| »|5)»
: = Obje
Equation
Obl:“ . 9 Use normal-tangential coordinate system ™ = Ge
Seomets
|||||||| P v Change of variables = 5 Body
#- Body = Boundar
> Dirichlet Conditions y
5 Bourn . Body force 2 I Divichlet = Model
u Displacement 1 | = Eq
Displacement 2 [ b
Displacement 3 |
Ire - bo
Body Set body properties Displacement 1 Condition [
initial @ Set boundary properties Displacement 2 Condition I
[Bound
Summary... Displacement 3 Condition I
|

Clear all

Normal Force

L]
Apply to boundaries: =
¥ Boundary 1; I™ Boundary 2
I© Boundary 3 ™ Boundary 4 =
Name: [BoundaryCondition 2
Y New I -+ add  OK I O Cancel | | | 2
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Case preparation SCtrain

 Definition of wall boundary condition

« SetDisplacement 1 and Displacement 2 to 0. ldentification number 1 refers to x-coordinate
and 2 refers to y-coordinate

» Select appropriate Edge on the Mesh
« Set name of boundary condition to Wall
« Click oK

 Definition of mechanical load g(x)
« Create a new boundary condition (Model->Boundary condition->Add..)
 Navigate to Linear elasticity

 Now we have to define linear load that points in y-direction and is linearly increasing along x-
direction. To do that:

« Goto Force 2 (remember, 2 refers to y-direction)
* The variable to specify: Vvariable Coordinate 1; Real; 0 0; 1 -1.0e7; End
« Set boundary condition name to Load

15
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« Explanation of Force 2 definition
« The semicolon in EImer FEM specifies the definition of new keyword

* The first keyword (Variable Coordinate 1) specifies that Force 2
Is changing its value along coordinate 1 (remember, 1 refers to x-
direction)

* Then the user can define a table of x (coordinate), F (force) values. So
the next keywords look like Wall

Real;

0 0;

1 -1.0e7;

End

« Keyword Real defines the type of numbers in a table

« Keyword 0 0 specifies that at x = Om, the force is F = ON

« Keyword 1 -1.0e7 specifies that at x = 1m, the force is F = —1.0e’N
« Keyword End specifies end of table

Load q(x)
Beam Q
x =0m x=1m
F=0N F =—-10e’N

16
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Case preparation SCtrain

* In case of elasticity solver, the Mesh boundaries are automatically set to O load
* Thus it is not necessary to define zero force on remaining two edges
* As an exercise, one can set the forces at these two edges to 0

17
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Running the case SCtrain

5. Computation
» Before running the case, one can observe the solver input file (extension .sif)
« SIF file is a file, generated by Elmer GUI.
* The file contains the case set-up with all the parameters specified by the user in EImer

GUI
* This file Is then taken as input by the Elmer kernel (EImerSolver), which then computes
the solution based on these parameters —
* Click on Sif->Generate andthen Sif->Edit.. [ b b [l o
* Here you can manually change properties in the
editor - |

Fila Mesh Model View  sif Run Help

Object » Edit.. ctri+s

18
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* To run the case, click “Save and run” button (see figure)

« This button will then ask you to select a project folder. Then it will save the changes and
run the case.

Convergence monitor <2> = % B¢
file view
1 . Convergence history
« Two windows open:
=
. El
« Convergence monitor > o
» 3
0.01 o
)
» Solver log - 8 oon
file Edit preference -5 0.0001
- ®
L‘)f b =] e o Ha 3 1e-05
* FrouTr - ;l s
260 0.1569E-08 @ 1e-06 o
270 0.1569€-08 =
280 0.1569E.08 1e-07
290 0.1569€-08
300 0.1569F-08 1e-08 o
310 0.1569F .08
320 0.1569€-08 109 4
330 0.1569€.08 E|
340 0.1569€-08 3
350 0.1569€-08 tetod o —
360 0.1569F-08 0 0.05 0.1 0.15 0.2 0.25 0.3 0.35 0.4 0.45 0.5 0.55 0.6 0.65 0.7 0.75 0.8 0.85 0.9 0.95 1
370 0.1569€-08 Iteration step
380 0.1569€-08
390 0.1569€-08
400 0.1569€-08
401 0.1106E-37
ComputeChange: NS (ITER=2) (NRM.RELC): ( 0.20543337€-01 0.94050920E-09 ) :: linear elasticity
StressSolver: All done
StressSolver:
ComputeChange: 55 (ITER=1) (NRM.RELC): ( 0.20543337E-01 2.0000000 ) :: linear elasticity
ResultOutputSolver: - e esaae e s
ResultOutputSolver: Saving with prefix: case
ResultOutputSolver: Creating list for saving - if not present
CreateListForSaving: Feld Varables for Saving
ResultOutputSolver: Saving in unstructured VTK XML [.vtu) format
VtuOutputSolver: Saving results in VITK XML format with prefix: case
VtuOutputSolver: Saving number of partitions: 1
ResultOutputSolver: ———eeeeeeeeeeee e I
ElmerSolver: *** Elmer Solver: ALL DONE ==+
ElmerSolver: The end
SOLVER TOTAL TIME(CPU,REAL) 3

19
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Post-processing SCtrain

« Use mouse wheel/right button to rotate and zoom result

20
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« To change coordinate of
displacement, navigate to
Properties—->coloring-
>displacement

Properties Information

Properties

Apply | % Delete

= Properties (case 10001 .viu)

v CellPoint Array Status

v ¥ Geometrylds
v displacement
= Display (UnstructuredGridRepress« o W
Representation =
e Magnitude
Coloring X
s Edit 2 P

« To get the maximum displacement, navigate

to Edit->Find data..

* In the dialog, select Point (s) and set

displacement (1) to “is min”

Find Data 2 {3l K

Create Selection
Find Point(s) ~ from case t0001.vitu

displacement (1) - s min v |

Run Selection Query

Current Selection (case_t0001.vtu : 0)

Show: Pointis) - Invert selection
Point ID Point Points_Magnitude displacems
0 3220 1. 0.0425808 0 1.00479 0.00388738 -0.0574192

Selection Display Properties

@ selection Color ¥ cell Labels - Point Labels

Freeze Selection Extract Selection Plot Selection Over Time X Close

21
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Exercise 1 SCtram

- Change maximum load on the right edge (at x = 1m) to F = —1.0e®N
and run the case again.

 Change the load again to F = —1.0e’N. Run the case and observe the
maximum displacement with increase of load

22
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Exercise 2 SCtram

« Add a new wall boundary condition to the right side of the beam (where x =
1m, set displacement in X and y direction to 0)

* Modify the load at the top to have the follo_vvingf:; derjoendency In X-direction.
What'is the maximum displacement in y-direction”

Wall 2

Wall 1

ANNRNNNY
/1177171

23
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Exercise 3 SCtram

 Transient loading
« Change Simulation Type t0 Transient (Setup->simulation type)
e Setthe Time Stepping Method to bdf
e Setthe Time step intervals to 200
« Setthe Time Step Sizesto le ™

24
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Loaded elastic beam - 3D SCtram

e Case definition

« A homogeneous, elastic beam is rigidly suggorted on
one end. On the other end, the force is 2000N due to
an attached object. The weight of the beam itself is
also included as additional load.

* The length of the beam is 1m, thickness is 0.05 m and
width is 0.1m

. _Yoggg’s modulus is 10 - 10° N /m? and Poisson’s ratio
is 0.

- Density of the material is 550kg /m?

« Goal
« Calculate displacement field of the beam

» Obtain the location and value of the maximum
displacement

* Calculate stress field

F =2000N

25
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Loaded elastic beam - 3D SCtram

1. Definition of domain of computation
 Import mesh into Elmer GUI
» Navigate to your folder and select beam3d.grd
« Use Mouse wheel/left button to rotate and zoom mesh

+ Verify that mesh consists of 6073 nodes and of 1200 quadratic hexahedral
elements

26
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Loaded elastic beam - 3D SCtram

Definition of type of physical problem i ey B e s
« Setthe simulation type to Steady e Come [
state e s : -
« Setequation to Linear elasticity :L — o
* In Linear elasticity, set checkbox B s d ——F.

Residual output |10

next to Active S B

BiCGStabl order [2
« We also want to compute stresses as a e e
post-processing step, so set checkbox of e | s |_vox | @
Calculate Stresses
 ClickonEdit solver settings:

e check Tterative method and set it to
GCR

« Set Preconditioningto ILU1

I™ Abort if the solution did not converge

27
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Loaded elastic beam - 3D SCtram

3. Definition of material properties

* Create a new material and define:
« Density,
* Poisson’s ratio and
* Young’'s modulus

 Assign the material to 3D beam

28
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4. Definition of boundary conditions

* Define zero displacement on left face that lies in
X-z plane (at the wall — refer to figure on slide
24)

* Note that second boundary condition distributes

the load of 2000N unlformly on the area of t -
w = 0.05m - 0.1m = 5.0e 3

* The weight of the beam should be defined
through Body Force

* Navigate to Model->Body force->Add..->Linear
elasticity

« Set the force in negative y-direction through mass of
beam and gravitational acceleration

* Apply the body force to the mesh body

ElmerGUI - /work/brankm/elmerg
File Mesh | Model View Sif Run Help
Q Setup... h l y ’
| 11§7
Ob| Equation 4
Geometr Material »
Input
+ Body
@ Boun: Rod¥¥ore '] Add.. |
BodyForce = IE] ¢
‘holtz Equation | Linear elasticity l Mesh Update | 4|»
Volume forces =
Force 1 |
Force 2 |
Force 3 |
Pressure |
Stress 6-vector |
Strain 6-vector |
Bodywise Dirichlet Conditions )
Displacemen t1 [
Displacemen t 2 [
Displacemen t3 [
Displacement 1 Condition [
B R A =i
Apply to bodies:
™ Body Property 1
Name: |BodyForce 2
© New | “~ Add I v OK I € cancel I
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Loaded elastic beam - 3D SCtram

5. Computation
 Generate and check SIF file
e Save the case and run it

30
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Loaded elastic beam - 3D SCtram

5. Post processing
« What is the maximum displacement and where is its location
 Plot displacements and Von mises stresses

dsoocement Mogniude
CO1 0C15 002 0025 003 0035 004 0045 005 0055  b6del2

l

31



SUPERCOMPUTING
KNOWLEDGE
PARTNERSHIP

Exercise SCtram

Gravity in x-direction
* The beam should be more rigid if the beam is orientated differently

« Change the direction of gravity and force of attached object in the negative x-
direction

32
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Exercise SCtram

Gravity in x-direction
* The beam should be more rigid if the beam is orientated differently

« Change the direction of gravity and force of attached object in the negative x-
direction

33
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Heat equation SCtrain

e Case definition

« A structure in L-shape is heated by
Internal source with magnitude of
1W /m3. The density of the structure is
1kg/m3 and the heat conductivity is

1W /mK. The temperature of boundaries
of the structure is set to 0.

e Goal

« Obtain temperature distribution in the
structure

34



SUPERCOMPUTING
KNOWLEDGE
PARTNERSHIP

Heat equation SCtrain

« Mathematically the problem to be solved
IS

—kAT =pf  on
T =0 onl

 Parameters
* k ... heat conductivity
T ... temperature
* f ... heat source

35
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Heat equation SCtrain

1. Definition of domain of computation
 Import mesh into Elmer GUI
« Navigate to your folder and select angle.grd
« Use Mouse wheel/left button to rotate and zoom mesh

 Verify that mesh was successfully imported and that it consists of 341 nodes
and of 300 bilinear elements

36
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2.

Definition of type of physical
problem

 Setthe simulation type to
Steady state

« Set equation to Heat equation

* In Heat equation check checkbox
nextto Active

Electrostatics ~ Heat Equation l Helmholtz Equat |'

Activate for this equation set —
Active =

Give Execution priority

Priority | ]
Options

Phase Change Model [None =]
Convection

Convection [None =]

Free text input

=
Apply to bodies:
I" Body Property 1
\ Edit Solver Settings I
Name: ||
“ New I «~ Add « OK | €) Cancel I

37



Heat equation

SCtrain

SUPERCOMPUTING
KNOWLEDGE
PARTNERSHIP

3. Definition of material properties

 Create a new material and define:
« Density,
« Heat conductivity (in Heat)

 Assign the material to the body

General | Electrostatics ~ Heat Equation | Helmholtz < |»

-

Properties

Heat Conductivity |

Heat Conductivity Model [None =
Emissivity |

Turbulent Prandtl Number [0.85
Enthalpy |
Specific Enthalpy |

Pressure Coefficient |
Free text input

]
Apply to bodies:
I” Body Property 1
\ Material library I
Name: |Material 2
“ New I “~ Add v OK l € Cancel I

38
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Heat equation SCtrain

4. Definition of boundary conditions Rei e Ceadcs =

General | Electrostatics | Heat Equation || Helm < |»
» Define zero temperature on boundaries e S
. . . . Temperature Condition |
« Temperature is defined under Dirichlet et Flux condions
' ' Heat Flux |
Ccon d 1 t 10nsSs Heat Transfer Coeff. | ]
External Temperature I
* Apply temperature to all boundaries i e |
e -
::c:':tit:r’\n e |None vl
Emissivity |
Radiation Roundarv Onen LI
Apply to boundaries:
I” Boundary 1 [T Boundary 2
I~ Boundary 3 [T Boundary 4
I” Boundary 5 I” Boundary 6 |

Name: |BoundaryCondition 3

© New | “~ Add v OK | © cancel |
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4. Definition of boundary conditions
* Define volumetric heat source in the structure

« A Body force represents the right-hand side of
the equation which in this case represents the
heat source

* Navigate to Body force

« Set Heat Source to 1 and apply the condition
to a body, then click Ok

BodyForce B ) P

Volume sources —

Heat Source [ ]
Friction Heat o

Joule Heat | |

Bodywise Dirichlet Conditions

Temperature [
Temperature Condition |—
Perfusion

Perfusion Rate [

Free text input

i
Apply to bodies:
r_ Z-‘,ru']'-g’ Froperty 1
Name: |BodyForce 4
Y New I “~ Add | o OK | €) cancel |

40



Heat equation SCtrain ™

5. Computation
 Generate and check SIF file
 Save the case and run it
Salver log

fle Edit preference fle View
IPEE R AT L) Convergence history
[FESTSOTvE Ter 1 ASSembly: 15 0.0 D.00 & 100 +
HeatSolve: iter: 1Solve: (s 0.00 0.00 4 Pl
HeatSolve: Result Norm : 7.7824030917542059€-002
HeatSolve: Relative Change : 2,0000000000000000
HeatSolve: 1
HeatSolve:
R s
HeatSolve: TEMPERATURE ITERATION 2 0,014
HeatSolve: Sl
HeatSolve: "
HeatSolve: Starting Assembly.
HeatSolve: Assembly; ?'10001-
HeatSolve: Assembly done n
10.4952€-11 %
ComputeChange: NS (ITER=2) (NRM,RELC): { 0.77624031€-01 0.36680970E-12 ) : heat equation o le06
HeatSolve: iter: 2 Assembly: (s) 0.00 0.01 >
HeatSolve:iter. 2Solve: (s) 0.00 0.00 'S
HeatSolve: Result Norm : 7.782403091757060SE-002 i
HeatSolve: Relative Change : 3.6680970111809652€-013 e 1e08+
ComputeChange: 55 (ITER=1) (NRM.RELC): ( 0.77824031€-01 2.0000000 ) : heat equation (4
ResultOutputSolve
ResultOutputSolver: Saving with prefix: case le-10+
ResultOutputSolver: Creating list for saving - if not present
CreateListForSaving: Field Vanables for Saving
ResultOutputSolver: Saving in unstructured VTK XML {.vtu) format
VtuOutputSolver: Saving results in VTK XML format with prefix: case le-12 4
VtuOutputSolver: Saving number of partitions: 1
ResultOutputSolve: S -
ElmerSolver: ** Elmer Solver: ALL DONE *** 1e-14 4
Elmersolver: The end T T T L T I L ST AL
SOLVER TOTAL TIME(CPUREAL: 013 047 A 0 0050101502 025 0.3 0.35 0.4 0.45 0.5 0.55 0.6 0.65 0.7 0.75 0.8 0.85 0.9 095 1
ELMER SOLVER FINISHED AT: 2021/06/29 12:37:01 B Iteration step
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SCtrain

6. Post-processing
* Open the result in ParaView

« What is the value of maximum temperature

» Plot temperature as a function of y-

coordinate at x = 0.5m

e GOtoFilters->Alphabetical->Plot On Intersection Curves
* In Properties, specify the intersection plane and then click Apply

T[OC] 0.15
0.1

0.056

— teamperature (1)

0.2 0.4 0.6 0.8 |
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6. Post-processing

Examination of computational time vs. number of
mesh nodes

Check output of Solver Log and read second line
from bottom to get the CPU time (see below)

ResultOULPULSOIVET: —eeeeeemee e
ElmerSolver: *** Elmer Solver: ALL DONE **+
EimerSolver: The end

SOLVER TOTAL TIMEICPU,REAL): 0.39 0.64
ELMER SOLVER FINISHED AT; 2021/06/29 13:25:53

Let’s increase the mesh density (i.e. increase the
number of nodes and elements) and rerun the
case

Navigate to Mesh->Configure..

In elmergrid->String:, change —autoclean
—relh 1.0t0 -autoclean -relh 0.6

Click Apply
Click Mesh->Remesh to recompute mesh

—
Obje

_
9

BM

™ Remesh

c # Divide surface..,

»+ Unify surface

+ Divide edge...
+ Unify edge

Clean up

ElmerGUI - /work/brank
file Mesh Model View Sf Run b
‘ S

Ctri+R

-nyglib

Element codes (for solver):
Codes: |
Defaults I v Apply

/ Configure 70X

Preferred generator

f tethb [stl smesh.poly .oft .oly .mesh

f* nglib {.in2d .st! brep .step .stp .iges .igs)
 elmergrid {.grd FONET .msh .mphtxt .unv)

tethb
Stnng: Irr ApVgl.414

Max H: |1000000

Fineness: [0.5

Bgmesh: |

eimergna

String:  |-autoclean -relh [
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 Run the case with denser mesh and observe the time difference

* Try to increase the density even more, for example change the value of
0.6 to 0.1

« Compare CPU times vs. number of mesh nodes
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Overview of commands SCtram

 elmerf ... Command to compile user defined Fortran routines
* ElmerGrid ... Command to generate and convert mesh data
* ElmerGUI ... Command to run the user interface

e ElmerSolver ... Command that reads SIF file and mesh data
and performs FEM calculations

* ElmerSolver mpi ... Command that performs parallel FEM
calculations
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Overview of commands SCtram

elmerft

e Users can define their own functions in Fortran that are then
passed to ElmerSolver

 User defined functions are defined In files with . £90 extension

* In SIF file, the reference to this file can be defined in boundary
condition block, material block,...

* ElImerSolver then calls this function by reading reference in SIF
file
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Overview of commands SCtram

Let’'s examine the zero temperature boundary condition in Heat transfer case

In SIF file, the boundary condition block is defined as:
Boundary Condition 1
Target Boundaries(l) = 1
Name = "zero temp"

Temperature = 0
End

Here, the temperature of the whole target boundary is set to O.

To call an external function, delete the Temperature = 0 line and add these two lines
Temperature = Variable Coordinate 2

Real Procedure "define temp" "defineTemp™

The first line means that temperature will be a variable of y-coordinate

The second line means that we are calling a function "defineTemp™ that is located in
define temp.£f90 file.
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Overview of commands SCtram

* File define temp.£f90 should look like this:

FUNCTION defineTemp (Model, elmer node, t, y) RESULT (elmer temperature)
USE DefUtils

TYPE (Model t) :: Model

TYPE (Nodes t) :: Nodes, EdgeNodes
INTEGER :: elmer node, 1

REAL (KIND=dp) :: t, Vv

$ Do your own calculations

END FUNCTION defineTemp
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The name of the function is defineTemp
* Input parameters are:
e Model -> structure of ElmerSolver, it contains different

parameters that we can access during function execution
* elmer node ->ID of the node that Iis currently being processed
e t-> current timestep
« y->variable specified in SIF file, in our case y-coordinate
« Qutput parameter is temperature, as defined in SIF file

 Inside this function we can now write different routines and specify
our own boundary condition
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Thank you for your attention!

http://sctrain.eu/
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